Blog Stuff

Registration

Thursday, April 24th, 2008 | Blog Stuff | 1 Comment

Hey all…. If any of you are trying to register on my blog to post or post comments please send me an email first to warn me. I’ve gotten a few registration requests lately with I email addresses I don’t recognize. Since being registered lets you see things others can’t i’m kind of careful about who I approve..

now back to your regularly scheduled programming

Tags: ,

Privacy and the blog

Wednesday, February 14th, 2007 | Blog Stuff | 1 Comment

One of the things I struggle with constantly is how much I can post on here due to the public nature of the blog. This stuff is open to pretty much everyone who dances into it which, while cool most of the time, proves a problem when I wanna talk about ‘pete stuff’ that I don’t want everyone to be privy to. While I love that friends, family, co-workers, and the rest of the world read my blog from time to time – some content isn’t always something I want everyone to read. (I think my boss would admit that too much information on my personal life isn’t always a good thing! ;))

So, inspired by Stephen, I’ve installed the post levels plugin that allows me to restrict some of my posts to certain groups of folks to protect the innocent! hehe…

What does that mean to you? All it means is if ya want to see some of the private stuff you have to register. All you have to do is click on the Register link on the right hand side. It’ll send you a login and password when ya register. You can change the password from there. Once you register I’ll set your privs so ya can see the appropriate stuff.

I promise to keep the hidden stuff to a minimum but a girl’s gotta have her secrets! hehe

Happy Wednesday! 🙂

How come

Monday, December 18th, 2006 | Blog Stuff | 5 Comments

no one is posting comments to my blog? Is commenting broken? Am I not writing anything comment-worthy… Or do you all just hate me?

(just kidding – just worried that the move to wordpress broke comments for folks)…

A new look

Saturday, November 25th, 2006 | Blog Stuff | 1 Comment

Once again I spent way too much time futzing with my blog when I should have been doing other things… But as a result I now have a brand shiny new WP blog with all of my old content and a shiny new look. This is an example of a powerful tool (MT) falling down because if QA and usability issues. I really liked MT cuz you can customize all sorts of stuff but unfortunately its power is also its downfall – every time I touched something I broke something else cuz their customization tools didn’t take into account things that the user changed on their own… So now i’m in WP.. For now… We’ll see how this works out..

The scoop for the record

Saturday, January 7th, 2006 | Blog Stuff, Geek Stuff | 2 Comments

I figured i’d log what was going on with my blog should someone else hit the problem… The basic problem was a few weeks or a month ago I started getting failures when using ecto to post to my blog. The failures showed up in an ecto error dialog as this:

Parsing Failure!

Could not parse response for “metaWeblog.editPost”. Please check the console log for more information.

Upon inspecting the log I saw this in the console:

500 Internal Server Error

Internal Server Error



The server encountered an internal error or

misconfiguration and was unable to complete

your request.

Please contact the server administrator,

xxx@swimfinssf.com and inform them of the time the error occurred,

and anything you might have done that may have

caused the error.

This stimyed me as the message basically told me nothing about what actually failed… I found a few posts indicating that it might be a file permissions problem on the server so I fixed permissions on every file I could find but that did nothing… I searched and searched and searched and finally thought to look in the server log itself… Server log contained this error

Out of memory!

Callback called exit at mt.cgi line 11.

BEGIN failed--compilation aborted at mt.cgi line 11.

[Fri Jan 6 08:04:04 2006] [error] [client 71.139.13.81] Premature end of script headers: /home/swimfins/swimfinssf.com/mt/mt.cgi

Looking at mt.cgi didn’t tell me anything – that line in the source is the ‘run the blog’ line (i.e. all of MT was run in that line so it didn’t help at all… So then I started googling again. This time I came upon a lone sparse article which indicated that this was caused by the server process running out of memory when trying to access the Berkeley DB databases I was using to store entries. The article indicated that I should switch to MySQL which I did.. and BINGO.. worked like a charm and increased the speed of MT at the same time…

Anyway.. not super interesting but I wanted to post it should some one else start googling after seeing the same errors. Hope it helps someone.

Happy hacking

New Style Sheet

Saturday, October 1st, 2005 | Blog Stuff | 2 Comments

So i’ve spent a few hours mucking with my style sheet to get it looking less like the stock one you can get from the MT folks and more like my own thing… The colors were picked by Kevin again but i’m still not 100% sold on the brown thing.. Unfortunately, i’m not coming up with a color pallette that I like better… So for now i’m gonna stick with this… Let me know what ya think (and if anyone else has better suggestions i’m ALL EARS…

But this is it for now… I’ll keep mucking with it and see if I can find something I like better… But for now i’m off to get a cocktail! 🙂

Happy Saturday! 🙂